Advertise on fullfatrr.com »

Home > Technical (L322) > Issue when starting car when it's hot ! (FIXED PAGE 2)
Post Reply  Down to end
Page 2 of 2 <12
Print this entire topic · 
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

Thanks for your reply Smile

Only thing left to replace is fuel pump and full assembly. maybe there's a check valve build into the top of the assembly.

There's nothing else which I can see which would allow pressure to drop so fast back to tank. :-/ as everything else has been replaced and no signs any leaks 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #435168 17th Apr 2017 11:42am
View user's profile Send private message View poster's gallery Reply with quote
Lenb



Member Since: 03 Sep 2014
Location: Leicester
Posts: 99

England 2004 Range Rover Vogue 4.4 V8 Adriatic Blue
Coolant temp sensor

I know you've checked the coolant sensor, but have you replaced it? (I'm tempted to try that one myself, not very expensive). Current: 2004 Vogue 4.4 V8 - 2000 P38 DHSE - 2004 Discovery 2
Previous: 1995 P38 DT Man - 1990 3.9 SE Classic, 1980 3.5 Classic 2dr

Post #435544 21st Apr 2017 12:21pm
View user's profile Send private message View poster's gallery Reply with quote
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

it may well be the coolant temp but when i checked the Code reader live data it read correctly for mine. but let me know if this fixes yours Smile

i don't really want to spend 350-400 for full fuel pump / assembly.

so i am going to install a check valve after the fuel pump in the fuel line. to see if this fixes the issue.

i will post the outcome just need to order one and arrange day i am free to fit. 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #435545 21st Apr 2017 12:57pm
View user's profile Send private message View poster's gallery Reply with quote
Lenb



Member Since: 03 Sep 2014
Location: Leicester
Posts: 99

England 2004 Range Rover Vogue 4.4 V8 Adriatic Blue

It amazes me that this seems quite a common problem (even across the BMW forums) and yet no one seems to have a definitive answer.
I can't see anything within the full pump that would want me to buy the full assembly. The actual pump I bought was a pieburg so original.
I'm away at the moment so will have a look when I get back after the weekend. I'll get a temp sensor from Land Rover so I can rule out cheap copies. Current: 2004 Vogue 4.4 V8 - 2000 P38 DHSE - 2004 Discovery 2
Previous: 1995 P38 DT Man - 1990 3.9 SE Classic, 1980 3.5 Classic 2dr

Post #435550 21st Apr 2017 2:20pm
View user's profile Send private message View poster's gallery Reply with quote
Jacckk



Member Since: 31 Dec 2015
Location: Durham
Posts: 10

2003 Range Rover Autobiography 4.4 V8 Giverny Green

I discovered that my warm start issue was actually caused by the LPG system. The diaphragm in the reducer was worn and was allowing gas to fill the manifold after the car was turned off, this would slowly leak away if left for long enough. I replaced the seals in the reducer and it's now perfect.

Post #435903 25th Apr 2017 9:20pm
View user's profile Send private message View poster's gallery Reply with quote
Lenb



Member Since: 03 Sep 2014
Location: Leicester
Posts: 99

England 2004 Range Rover Vogue 4.4 V8 Adriatic Blue

I'm not sure about b348xyx, but I'm not lpg - just purely petrol. Current: 2004 Vogue 4.4 V8 - 2000 P38 DHSE - 2004 Discovery 2
Previous: 1995 P38 DT Man - 1990 3.9 SE Classic, 1980 3.5 Classic 2dr

Post #435905 25th Apr 2017 9:26pm
View user's profile Send private message View poster's gallery Reply with quote
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

thanks for your update jacckk and glad you got yours sorted Smile

and yes lenb mines just petrol no LPG on mine.

I have some parts coming today will post outcome when fitted. 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #435946 26th Apr 2017 9:48am
View user's profile Send private message View poster's gallery Reply with quote
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

FIXED !!!! starts perfect every time now !!!!


Installed a check valve (Sytec Motorsport One Way Valve For Fuel 8mm Push On In Black - OWVS008-BK) just after the fuel pump on the hard plastic fuel line. (blue line)

theirs not much room in the to work, but heat gun to loosen the plastic pipe up and push the fuel check valve in the line.. hose clamp tightly after... some swear words later..

Fixed my issue, so my new fuel pump either has a bad check valve or the Assembly has bad check valve somewhere.

The fuel pressure is staying as it should now as well no fuel pressure lose over time.

So after buying Crank Sensor, Cam Sensors and refurb injectors its could been fixed with a 12 check valve ! oh well as least car has lots new parts ! and to be fair the car is running nicer with the new injectors anyways.

hope this helps someone else out there.





 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #436072 27th Apr 2017 12:08pm
View user's profile Send private message View poster's gallery Reply with quote
Lenb



Member Since: 03 Sep 2014
Location: Leicester
Posts: 99

England 2004 Range Rover Vogue 4.4 V8 Adriatic Blue

Sounds good to me Thumbs Up

Would love to know the reason why it's worse when hot though - just so I can get my head around it. Current: 2004 Vogue 4.4 V8 - 2000 P38 DHSE - 2004 Discovery 2
Previous: 1995 P38 DT Man - 1990 3.9 SE Classic, 1980 3.5 Classic 2dr

Post #436080 27th Apr 2017 2:05pm
View user's profile Send private message View poster's gallery Reply with quote
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

heat from engine helps push the fuel back down the pipes ?

or ECU gives engine more fuel faster when cold ?

god knows but tested starting 30mins, 2hours, 1hour and starts perfectly every time now.. just like it use to Smile so i am happy with that. 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #436081 27th Apr 2017 2:08pm
View user's profile Send private message View poster's gallery Reply with quote
b348xyx



Member Since: 29 Sep 2016
Location: Kent
Posts: 196

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

heres a video after car been left sitting for an hour after 20mins drive to get car to temperature.

Starts like it use to now.

With non return valve fitted and starting normal.






Below without non return valve.

 2003 Range Rover 4.4 Litre V8 - Adriatic blue

Post #436083 27th Apr 2017 2:38pm
View user's profile Send private message View poster's gallery Reply with quote
Lenb



Member Since: 03 Sep 2014
Location: Leicester
Posts: 99

England 2004 Range Rover Vogue 4.4 V8 Adriatic Blue

Going to get a valve ordered 😀 Current: 2004 Vogue 4.4 V8 - 2000 P38 DHSE - 2004 Discovery 2
Previous: 1995 P38 DT Man - 1990 3.9 SE Classic, 1980 3.5 Classic 2dr

Post #436084 27th Apr 2017 2:41pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 2 of 2 <12
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2017 Futuranet Ltd & Martin Lewis


Switch to Mobile site