Advertise on fullfatrr.com »

Home > Technical (L405) > Power steering failed L405
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
1959terry



Member Since: 28 Apr 2014
Location: London
Posts: 117

United Kingdom 2015 Range Rover Vogue SE SDV8 Santorini Black
Power steering failed L405

Just wondering if this is common?

Stopped at the traffic lights and the stop start engaged, when the lights changed to green I pulled away and had no power steering!!! managed to pull around the corner and stoped, I turned the car off and restarted, when restarted it was fine??

This happened last week and it has not happened since however I was wondering if anyone else has experienced this???

Terry 2015 Range Rover VSE 4.4 SDV8. 1998 BMW 840 Sport, 2008 Aston Martin DB9
2009 Triumph Bonneville, 1959 Triumph Bonneville, 2014 Suzuki Gladius

Post #494546 3rd Nov 2018 9:27pm
View user's profile Send private message View poster's gallery Reply with quote
nubbin



Member Since: 23 Jan 2012
Location: Sheffield
Posts: 113

United Kingdom 

I am not a mechanic, but the first thing to check would be the fluid in the reservoir, check for any obvious fluid leaks, then book it in for a check over. My money would be on a small PS fluid leak. I have an old SL55 AMG which has a very slow leak somewhere in the suspension system which eventually causes the system to throw an error. Takes about 3 years for this to happen after a top up of fluid - maybe your PS fluid is doing the same?

Post #494869 7th Nov 2018 9:04am
View user's profile Send private message View poster's gallery Reply with quote
GraemeS



Member Since: 06 Mar 2015
Location: Wagga area
Posts: 717

Australia 2012 Range Rover Autobiography TDV8 Bournville

Does it have electric steering?

Post #494871 7th Nov 2018 9:12am
View user's profile Send private message View poster's gallery Reply with quote
1959terry



Member Since: 28 Apr 2014
Location: London
Posts: 117

United Kingdom 2015 Range Rover Vogue SE SDV8 Santorini Black

I believe that it is electric but it may also have a oil reservoir?

Forgot to mention that I have fitted a Ghost immobiliser recently which connects into the Canbus, I wonder if this may have caused it?

btw it has not re-occured since. 2015 Range Rover VSE 4.4 SDV8. 1998 BMW 840 Sport, 2008 Aston Martin DB9
2009 Triumph Bonneville, 1959 Triumph Bonneville, 2014 Suzuki Gladius

Post #494951 7th Nov 2018 9:40pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis


Switch to Mobile site