Advertise on fullfatrr.com »

Home > Technical (L322) > New ignition switch fitted, not cranking
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue
New ignition switch fitted, not cranking

Hello
I have a 2004 TD6 Vogue, I had some ignition issues such as the ignition coming on and off by itself, thesE symptoms occured after it sat for about 5 days. I fitted a new ignition switch and it won't crank, not even a click from the starter. If I put the old one in, then it starts straight away. I've left the negative off the battery for a short while before reconnecting it, I'm going to leave it disconnected overnight and see what happens. I will probably put the old switch back in again to drive it again. It is very strange, anyone have any ideas.

Thanks

Post #497856 7th Dec 2018 4:51pm
View user's profile Send private message View poster's gallery Reply with quote
Grofus



Member Since: 24 Mar 2017
Location: Co Clare
Posts: 393

Ireland 2007 Range Rover Vogue TDV8 Zermatt Silver

Check the continuity of the new switch
Could be faulty 2007 Vogue TDV8 in Zermatt Silver with Charcoal

Post #497863 7th Dec 2018 5:52pm
View user's profile Send private message View poster's gallery Reply with quote
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue

Do you know pins I need to check continuity through.
Thanks

Post #497866 7th Dec 2018 6:11pm
View user's profile Send private message View poster's gallery Reply with quote
Grofus



Member Since: 24 Mar 2017
Location: Co Clare
Posts: 393

Ireland 2007 Range Rover Vogue TDV8 Zermatt Silver

No but you should be able to work it out from the loom. One will be a common ground. The others will be the various live feeds. They should all give a value through the common ground. 2007 Vogue TDV8 in Zermatt Silver with Charcoal

Post #497868 7th Dec 2018 6:25pm
View user's profile Send private message View poster's gallery Reply with quote
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue

So checked all the connections in both positions of ignition, all are the same except for the black and yellow wire going to the EWS unit. On the new switch, when turning to crank it over, there's a reading of 0.13 v and drops to 0, and on the old one it goes to around 12v before going back to 0.

Post #497908 8th Dec 2018 11:07am
View user's profile Send private message View poster's gallery Reply with quote
Cam-Tech-Craig



Member Since: 03 Aug 2011
Location: Gloucestershire
Posts: 12204

England 2007 Range Rover Autobiography TDV8 Java Black

I haven't touched one of these for ages but aren't they coded to the car? Hence why your immobiliser won't allow the starter to engage?...

Post #497909 8th Dec 2018 11:13am
View user's profile Send private message View poster's gallery Reply with quote
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue

From what I've read, the ring antenna is above the switch and that's what sends the key info to the EWS. So this should theoretically work without any coding.

Post #497910 8th Dec 2018 11:19am
View user's profile Send private message View poster's gallery Reply with quote
Cam-Tech-Craig



Member Since: 03 Aug 2011
Location: Gloucestershire
Posts: 12204

England 2007 Range Rover Autobiography TDV8 Java Black

So, exactly what have you changed?

Post #497911 8th Dec 2018 11:22am
View user's profile Send private message View poster's gallery Reply with quote
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue

Just the ignition switch.

Post #497912 8th Dec 2018 11:27am
View user's profile Send private message View poster's gallery Reply with quote
Cam-Tech-Craig



Member Since: 03 Aug 2011
Location: Gloucestershire
Posts: 12204

England 2007 Range Rover Autobiography TDV8 Java Black

The metal barrel or the electrical black box?

If you've replaced the barrel, what key are you using?

Post #497913 8th Dec 2018 11:29am
View user's profile Send private message View poster's gallery Reply with quote
Qahmed95



Member Since: 28 Jan 2017
Location: Birmingham
Posts: 10

United Kingdom 2004 Range Rover Vogue Td6 Monte Carlo Blue

So just changed the electrical box, I opened it up and found some black residue on pin 8 which is for the EWS, I was cleaning it as I was replying to you. Just installed it in the car and it's running perfectly now. The residue was only on the one contact, that's why the ignition was working but it felt as if the immobiliser was not allowing the engine to turn over.

Post #497914 8th Dec 2018 11:33am
View user's profile Send private message View poster's gallery Reply with quote
Grofus



Member Since: 24 Mar 2017
Location: Co Clare
Posts: 393

Ireland 2007 Range Rover Vogue TDV8 Zermatt Silver

Thumbs Up 2007 Vogue TDV8 in Zermatt Silver with Charcoal

Post #497915 8th Dec 2018 11:38am
View user's profile Send private message View poster's gallery Reply with quote
Cam-Tech-Craig



Member Since: 03 Aug 2011
Location: Gloucestershire
Posts: 12204

England 2007 Range Rover Autobiography TDV8 Java Black

Great news Thumbs Up

Post #497916 8th Dec 2018 11:39am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis


Switch to Mobile site