Advertise on fullfatrr.com »

Home > LPG > LPG not switching over
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Pluribus



Member Since: 12 Feb 2017
Location: Yalding - Kent
Posts: 16

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue
LPG not switching over

Hi

I've got a BRC system in my 2003 petrol L322 Vogue. It worked fine when I purchased it a few weeks ago. I refueled with a full tank of LPG but it is refusing to switch over to gas. It will just beep for about 10 mins as if its empty, them if it does decide to switch, the engine immediately cuts out and I lose all power until I turn it back to petrol again.

I've got the same system in my Freelander so I'm well used to it, I've just never had this problem before.

The car was recently serviced and all fluids were changed. It has a full tank of lpg and a full tank of petrol. The fill indicator on the LPG switch shows it's full as does the gauge on the tank.

My local LPG guy wont work on a system thats charged as he has no filtration in his workshop so I would like to try and sort this out before having to purge a full tank before taking it over to him...

Does anyone have any ideas?

Post #430712 10th Mar 2017 5:25pm
View user's profile Send private message View poster's gallery Reply with quote
dingg1



Member Since: 29 Jun 2013
Location: PORTUGAL
Posts: 955

2007 Range Rover Vogue SE 4.2 SC V8 Stornoway Grey

ask here

http://lpgforum.co.uk

if your man won't look at it with gas in the tank - find someone else IMO

my 'guess' would be solenoid operated valve stuck shut at tank

Post #430716 10th Mar 2017 5:43pm
View user's profile Send private message View poster's gallery Reply with quote
wood78987



Member Since: 03 Mar 2016
Location: South Wales
Posts: 107

United Kingdom 2012 Range Rover Westminster 4.4 V8 Santorini Black

Agreed on the solenoid valve.
They get clogged up with deposits from the gas so I'd say this is the likely cause. 2012 Westminster 4.4 TDV8
2003 AB LE 4.4 V8 LPG (sold)

Post #430719 10th Mar 2017 6:04pm
View user's profile Send private message View poster's gallery Reply with quote
Pluribus



Member Since: 12 Feb 2017
Location: Yalding - Kent
Posts: 16

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

Thanks, I'll post over there now.

Post #430720 10th Mar 2017 6:04pm
View user's profile Send private message View poster's gallery Reply with quote
Pluribus



Member Since: 12 Feb 2017
Location: Yalding - Kent
Posts: 16

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

wood78987 wrote:
Agreed on the solenoid valve.
They get clogged up with deposits from the gas so I'd say this is the likely cause.


I've not had to do this before. How easy are they to change? Is the solenoid valve easy to access?

Post #430721 10th Mar 2017 6:25pm
View user's profile Send private message View poster's gallery Reply with quote
Pluribus



Member Since: 12 Feb 2017
Location: Yalding - Kent
Posts: 16

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

I've just been out to the car and the engine management light came on. Read the fault code with Torque and it said O2 sensor heater circuit malfunction (bank 2, sensor 1).

Could this heater circuit have anything to do with it as I know it must be a certain temp before the gas will switch. I've not had any cause to use the heaters since I got it so no idea if they were working or not - but this is the first time the engine light has come on.


Can I fix this problem myself or do I need the LPG guy to do this also?

Regards

Ian

Post #430724 10th Mar 2017 6:37pm
View user's profile Send private message View poster's gallery Reply with quote
Robert



Member Since: 25 Oct 2011
Location: Perigueux
Posts: 2191

France 2007 Range Rover Vogue 4.4 V8 Zambezi Silver

There is a little filter in the pipeline under the bonnet, if that is not replaced every 20 k it might block. Bear in mind I'm a non tech.

Post #430813 11th Mar 2017 5:54pm
View user's profile Send private message View poster's gallery Reply with quote
Lukie



Member Since: 27 Sep 2016
Location: Liverpool
Posts: 433

2002 Range Rover Vogue 4.4 V8 Zambezi Silver

did you get sorted?

Post #442331 22nd Jun 2017 7:57pm
View user's profile Send private message View poster's gallery Reply with quote
Pluribus



Member Since: 12 Feb 2017
Location: Yalding - Kent
Posts: 16

United Kingdom 2003 Range Rover Vogue 4.4 V8 Adriatic Blue

Yes I did, and I apologise for not updating this forum. I hate it when people do that!

It was both the solenoid and the wiring to the vaporiser under the bonnet. The idiot (I mean professional installer) decided in his professional opinion that the best place to install that wiring was along the rear wheel well where a clip failed and left the wiring chafing against the wheel. It had split one of the wires so no signal was getting through to the solenoid.

If it hadnt been for the excellent work of my favoured installer (Neil of Medway Dual Fuel), we may never have found it.

All up and running, he even gave it a remap as part of the service.

Post #442446 23rd Jun 2017 5:16pm
View user's profile Send private message View poster's gallery Reply with quote
Lukie



Member Since: 27 Sep 2016
Location: Liverpool
Posts: 433

2002 Range Rover Vogue 4.4 V8 Zambezi Silver

Good to hear all is well

Post #442476 23rd Jun 2017 9:13pm
View user's profile Send private message View poster's gallery Reply with quote
Johnsd1v8



Member Since: 06 Jul 2017
Location: Cheshire
Posts: 190

United Kingdom 2004 Range Rover Autobiography Td6 Zambezi Silver

Glad you got it sorted

Post #443723 6th Jul 2017 2:35pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2021 Futuranet Ltd & Martin Lewis


Switch to Mobile site