Advertise on fullfatrr.com »

Home > In Car Electronics (L322) > Crackly bluetooth phone - 2010 L322
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
hughjayteens



Member Since: 21 Mar 2010
Location: South East
Posts: 55

2005 Range Rover Vogue Td6 Java Black
Crackly bluetooth phone - 2010 L322

Hi all,
Recently bought a 2010 Facelift TDV8 and the bluetooth is very crackly when on the phone. Audio system otherwise crackle free and sounds great!

Any ideas?

Post #508697 14th Mar 2019 3:57pm
View user's profile Send private message View poster's gallery Reply with quote
jonlewis



Member Since: 06 Nov 2012
Location: UK
Posts: 287

2007 Range Rover Vogue TDV8 Buckingham Blue

May be worth putting the phone in the boot and see if it is still crackling.

Interference can be an issue it seems. If not, then it can be a failing module. 2011 Stornaway Grey 5.0SC Autobiography

Post #508741 14th Mar 2019 7:37pm
View user's profile Send private message View poster's gallery Reply with quote
hughjayteens



Member Since: 21 Mar 2010
Location: South East
Posts: 55

2005 Range Rover Vogue Td6 Java Black

Thanks I'll give that a try.

I recall a similar issue with a faulty unit in my 2004 TD6 and LR did an exchange unit. Do you know if they still offer such a thing?

Post #508746 14th Mar 2019 8:21pm
View user's profile Send private message View poster's gallery Reply with quote
Tugger



Member Since: 28 Feb 2019
Location: Scotland
Posts: 87

Scotland 2009 Range Rover Westminster TDV8 Stornoway Grey

What sort of thing could cause interference here? I've got same symptoms - phone audio is crackling when in the front but fine when I sit in the boot. Makes driving a real PITA from back there though Laughing

There is a Tracker (as in the brand name) hard wired into the car quite near the BT module - not mine, it was there when I bought it. I'm thinking of finding an auto electrician to remove it, just wondering if that might related? Not even sure GPS and BT are anywhere near each other on the frequency spectrum..? 2009 Grey Westie in Scotland

Post #509691 24th Mar 2019 4:10pm
View user's profile Send private message View poster's gallery Reply with quote
fin



Member Since: 20 Oct 2010
Location: South East London
Posts: 40

United Kingdom 2013 Range Rover Autobiography SDV8 Causeway Grey

As my Bluetooth unit started to fail I had the same issue. It wasn’t until it failed completely I opened it up (really easy) and saw corrosion on the PCB. I used a tooth brush and contact cleaner from Halfords thinking it was broken anyway and then it worked faultlessly. Not promising anything but worth a look.

Here a picture of the PCB in my Bluetooth unit before I cleaned it, I didn’t take one afterward sorry, I guessed the corrosion was causing some of my interference then failure


Last edited by fin on 5th Apr 2019 11:33pm. Edited 1 time in total

Post #511078 5th Apr 2019 11:30pm
View user's profile Send private message View poster's gallery Reply with quote
fin



Member Since: 20 Oct 2010
Location: South East London
Posts: 40

United Kingdom 2013 Range Rover Autobiography SDV8 Causeway Grey

Pcb

Post #511079 5th Apr 2019 11:30pm
View user's profile Send private message View poster's gallery Reply with quote
Tugger



Member Since: 28 Feb 2019
Location: Scotland
Posts: 87

Scotland 2009 Range Rover Westminster TDV8 Stornoway Grey

Cheers Fin, that's really helpful - I'll take a look at this on mine tomorrow and report findings.

Had the old tracker unit removed, no difference in BT call quality. Didn't think it would be that TBH but worth a shot. Interestingly, was using the phone the other day and apologised to the caller for the poor quality - they said it was fine their end so it must just be on the output of the call into the speakers that the problem lies. 2009 Grey Westie in Scotland

Post #511161 6th Apr 2019 8:53pm
View user's profile Send private message View poster's gallery Reply with quote
nickt68



Member Since: 05 Nov 2010
Location: Herts
Posts: 41

2009 Range Rover Vogue TDV8 Santorini Black

Mine has the crackly call quality too but also a bit of a lucky dip as to whether it connects at all. Similarly, sometimes the name of caller displays on the screen when I receive a call and sometimes just their number (I.e. from a known ‘stored’ caller). The call list is very hit and miss too!

Other than that, it works absolutely perfectly 🤪

Post #511186 7th Apr 2019 7:47am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2019 Futuranet Ltd & Martin Lewis


Switch to Mobile site